T
T
TODO•SEC
Search…
Tune & Optimize EtherChannel Operations
From Cisco's Networking Academy ENCOR Lab Guide

5.1.4 Lab - Tune & Optimize EtherChannel Operations

Part 1: Build the Network and Configure Basic Device Settings

Open Standard: Link Aggregation Control Protocol (LACP), maintains EtherChannel Bundles. LACP supports 8 active members and 8 standby members in each bundle. Minimum and Maximum # of links and timing of LACP packets may be configured.
1
DSW1:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
configure terminal
8
!
9
hostname DSW1
10
!
11
banner motd # D1, Tuning EtherChannel #
12
spanning-tree mode rapid-pvst
13
!
14
!
15
line con 0
16
!
17
exec-timeout 0 0
18
!
19
logging synchronous
20
!
21
exit
22
!
23
interface range GigabitEthernet 0/0 - 3
24
!
25
!
26
switchport trunk encapsulation dot1q
27
!
28
switchport mode trunk
29
no shutdown
30
!
31
exit
32
!
33
clock timezone UTC -5
34
!
35
end
36
!
37
write memory
38
!
39
40
DSW2:
41
!
42
enable
43
!
44
terminal length 0
45
!
46
configure terminal
47
!
48
hostname DSW2
49
!
50
banner motd # D1, Tuning EtherChannel #
51
spanning-tree mode rapid-pvst
52
!
53
!
54
line con 0
55
!
56
exec-timeout 0 0
57
!
58
logging synchronous
59
!
60
exit
61
!
62
interface range GigabitEthernet 0/0 - 3
63
!
64
!
65
switchport trunk encapsulation dot1q
66
!
67
switchport mode trunk
68
no shutdown
69
!
70
exit
71
!
72
clock timezone UTC -5
73
!
74
end
75
!
76
write memory
77
!
Copied!

Part 2: Tune LACP based EtherChannel

EtherChannel bundles using LACP as its negotiation protocol can have up to 16 assigned members, with 8 active ports passing traffic and 8 ports on standby.
LACP bundle switched negotiate a master/slave relationship and the designated master switch makes the decision on which members are active and which are in "hot standby" mode when the number of members in the bundle exceeds 8.
Minimum and Maximum # of ports in a port channel can be configured.
DSW1 & DSW2 EtherChannel Bundle w/ LACP as negotiation protocol with 2 links and a max. of 3. Manually set a master. Enable LACP fast packets and reduce time out period from 30 to 1 second(s).
Configure Master Switch Criteria
Each LACP switch has a system-ID value. SW with lowest system-ID is the master. System-ID = system priority (32768 by default + base MAC Address). The priority value for LACP doesn't scale in multiples of 4096. (Unlike Spanning Tree Protocol).
Use "show lacp sys-id" (display sys-id) on DSW1-DSW2.
1
DSW1:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
show lacp sys-id
8
!
9
10
Output:
11
12
DSW1#show lacp sys-id
13
32768, 5254.000d.8000
14
15
DSW2:
16
!
17
enable
18
!
19
terminal length 0
20
!
21
!
22
show lacp sys-id
23
!
24
25
Output:
26
27
DSW2#show lacp sys-id
28
32768, 5254.0019.8000
Copied!
Modify LACP sys-ID in DSW2 (lacp system-priority 1)
1
DSW2:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
configure terminal
8
!
9
no ip domain-lookup
10
!
11
lacp system-priority 1
12
!
13
end
14
!
15
write memory
16
!
17
show lacp sys-id
18
!
Copied!
Configure bundle size and member preferences
Interfaces are selected to be included in the active bundle based on their interface id. Lower numbered interfaces are added to the bundle until maximum size. Remaining interfaces are put in hot standby mode
Shutdown interfaces between DSW1 & DSW2
1
DSW1 & DSW2:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
show ip interface brief
8
!
9
configure terminal
10
!
11
no ip domain-lookup
12
!
13
interface range GigabitEthernet0/0 - 3
14
!
15
shutdown
16
!
17
end
18
!
19
write memory
20
!
21
show ip int brief
22
!
Copied!
Configure links connecting DSW1 & DSW2 into a LACP EtherChannel bundle. Use Channel Group number 12 and the Active Mode. Configure interfaces for LACP fast
1
DSW1 & DSW2:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
sh ip interface brief
8
!
9
configure terminal
10
!
11
no ip domain-lookup
12
!
13
interface range GigabitEthernet0/0 - 3
14
!
15
channel-group 12 mode active
16
!
17
lacp rate fast
18
!
19
no shutdown
20
!
21
end
22
!
23
write memory
24
!
25
show EtherChannel summary
26
!
Copied!
Configure port-channel 12 on DSW1 & DSW2 w/ a LACP minimum bundle size of 2 interfaces, maximum bundle size of 3 interfaces. Max value is only needed in master switch. Configuring it on both ends may help with troubleshooting. Verify that the EtherChannel bundle has formed and note the ports that are included versus the port that is in hot standby mode. (show EtherChannel summary).
1
DSW1 & DSW2:
2
!
3
enable
4
!
5
terminal length 0
6
!
7
sh ip interface brief
8
!
9
configure terminal
10
!
11
no ip domain-lookup
12
!
13
interface port-channel 12
14
!
15
port-channel min-links 2
16
!
17
lacp max-bundle 3
18
!
19
end
20
!
21
write memory
22
!
23
show EtherChannel summary
24
!
25
show lacp internal
26
!
Copied!

Part 3: Explore EtherChannel Load Balancing

Load Balancing method in EtherChannel is a global Settings on the switch. All Ether-channels in a SW will use the method selected. Load Balancing methods used at either end of the EtherChannel Bundle do not have to match.
By default Cisco Catalyst 3650 and 2960 SW load-balance using MAC Address.
1
!
2
enable
3
!
4
show etherchannel load-balance
5
!
6
7
8
DSW2#show etherchannel load-balance
9
EtherChannel Load-Balancing Configuration:
10
src-dst-ip
11
12
EtherChannel Load-Balancing Addresses Used Per-Protocol:
13
Non-IP: Source XOR Destination MAC address
14
IPv4: Source XOR Destination IP address
15
IPv6: Source XOR Destination IP address
Copied!
Last modified 8d ago