WIP - 1.1.2 Lab - Implement Inter-VLAN Routing

Topology:

  • 2 Routers

  • 2 Switches

  • 4 Linux Hosts

Addressing Table

DeviceInterfaceIPv4 AddressIPv6 AddressIPv6 Link-Local

R1

G0/0/1

10.1.13.1/24

2001:DB8:ACAD:10D1::1/64

FE80::1:1

S0/1/1

10.1.3.1/24

2001:DB8:ACAD:1013::1/64

FE80::1:2

D1

G1/0/11

10.1.13.13/24

2001:DB8:ACAD:10D1::D1/64

FE80::D1:1

VLAN50

10.2.50.1/24

2001:DB8:ACAD:1050::D1/64

FE80::D1:2

VLAN60

10.2.60.1/24

2001:DB8:ACAD:1060::D1/64

FE80::D1:3

R3

S0/1/1

10.1.3.3/24

2001:DB8:ACAD:1013::3/64

FE80::3:1

G0/0/1.75

10.3.75.1/24

2001:DB8:ACAD:3075::1/64

FE80::3:2

G0/0/1.85

10.3.85.1/24

2001:DB8:ACAD:3085::1/64

FE80::3:3

D2

VLAN75

10.3.75.14/24

2001:DB8:ACAD:3075::D2/64

FE80::D2:1

PC1

NIC

10.2.50.50/24

2001:DB8:ACAD:1050::50/64

EUI-64

PC2

NIC

10.2.60.50/24

2001:DB8:ACAD:1060::50/64

EUI-64

PC3

NIC

10.3.75.50/24

2001:DB8:ACAD:3075::50/64

EUI-64

PC4

NIC

10.3.85.50/24

2001:DB8:ACAD:3085::50/64

EUI-64

Goals:

Step 1. Build Network + Configure Device Settings

Step 2. Configure + Verify Inter-VLAN Routing on a L3 SW

Step 3. Configure and Verify Router-based Inter-VLAN Routing

Step 4. Examine CAM + CEF Details

Background/Scenario

Method of moving packets and frames from one interface to the other has changed over the years. We'll configure Inter-VLAN Routing and examine the different tables used in making forwarding decisions.

Step 1. Build Network + Configure Device Settings

  1. Ensure devices are connected as per diagram.

  2. Implement the following configuration on each Device:

Router R1

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname R1 
! 
line con 0 
! 
logging synchronous 
! 
exit 
! 
banner motd # This is R1, Inter-VLAN Routing Lab # 
! 
clock timezone UTC -5 
! 
end 
! 
write memory 
!

Switch DSW1

! 
Enable 
! 
configure terminal
! 
no ip domain-lookup 
! 
hostname DSW1 
! 
line con 0 
! 
logging synchronous 
! 
exit 
! 
banner motd # This is DSW1, Inter-VLAN Routing Lab # 
! 
clock timezone UTC -5 
! 
end 
! 
!
write memory
! 

Router R3

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname R3 
! 
line con 0 
! 
logging synchronous 
! 
exit 
! 

Switch DSW2

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW2 
! 
line con 0 
! 
logging synchronous 
! 
exit 
! 
banner motd # This is DSW2, Inter-VLAN Routing Lab # 
! 
clock timezone UTC -5 
! 
end 
! 
write memory 

Step 2. Configure + Verify Inter-VLAN Routing on a L3 SW

Step 1. - D1 - Configure Inter-VLAN Routing

A. Configure D1 to support IP routing & IPv6 Unicast Routing

Switch DSW1

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW1 
! 
ip routing 
! 
ipv6 unicast-routing 
! 
end 
! 
write memory 
!

B. Create the VLANs and name them as per topology

Switch DSW1

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW1 
! 
vlan 50 
! 
name Group50 
! 
vlan 60 
! 
name Group60 
! 
exit 
! 
end 
! 
write memory 
!

C. Assign the G1/0/23 to VLAN 50 and G1/0/24 to VLAN 60

Switch DSW1

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW1 
! 
interface g1/0/23 
! 
switchport mode access 
! 
switchport access vlan 50 
! 
no shutdown 
! 
interface g1/0/24 
! 

D. Create the Switched Virtual Interfaces (SVI) that will support VLAN 50 and VLAN 60

Switch DSW1

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW1 
! 
interface vlan 50 
! 
ip address 10.2.50.1 255.255.255.0 
! 
ipv6 address fe80::d1:2 link-Local 
! 
ipv6 address 2001:db8:acad:1050::d1/64 
! 
no shutdown 
! 
exit 
! 
interface vlan 60 
! 
ip address 10.2.60.1 255.255.255.0 
! 
ipv6 address fe80::d1:3 link-Local 
! 
ipv6 address 2001:db8:acad:1060::d1/64 
! 
no shutdown 
! 
exit 
!

E. Configure PC1 with the addresses specified in the Addressing Table. Further assign default gateways of 10.2.50.1 & 2001:db8:acad:1050::d1

F. Configure PC2 with the addresses specified in the Addressing Table Further assign default gateways of 10.2.60.1 & 2001:db8:acad:1060::d1

G. From PC1, ping PC2s IPv4 & IPv6 address. ECHO response means D1 is performing Inter-VLAN Routing.

H. Examine the MAC address table on D1 - show mac address-table dynamic - PC1 & PC2 mac addresses listed with the ports the are connected to.

Step 2. D1 - configure a routed port and default routes towards R1

A. Configure interface G1/0/11 as a routed port with addressing as specified in the topology diagram.

B. Verify that interface G1/0/11 is not in VLAN database - show vlan brief | include g1/0/11 - empty

C. Configure static default routes for IPv4 & IPv6 toward interface address at R1

Step 3. R1 - Configure interface addressing and static routing

A. Configure IPv6 unicast routing on R1

B. Configure the interfaces on R1 addressed

C. Configure routing on R1. Configure Static Routes to the networks supported by D1 + default route for everything else

D. From R1, ping PC2 with IPv4 and IPv6. All pings should be successful.

Part 3. Configure and Verify Router-based Inter-VLAN Routing

Check SDM template supports >0 IPv6 Unicast Routes - "show sdm prefer"

If == 0**:**

  1. Change to an SDM template that supports IPv6 using

"sdm prefer 'template_name'"

2. Global configuration command.

3. Reboot After template has been applied.

Step 1. Configure D2 to support the required VLANs

A. Create the VLANs and name them as specified in the topology. Create VLAN0999 and name it "Native VLAN"

Switch DSW2

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW2 
! 
vlan 75 
! 
name Group75 
! 
exit 
! 
vlan 85 
! 
name Group85 
! 
exit 
! 
vlan 999 
! 
name NativeVLAN 
! 
exit 
! 
end 
! 
write memory 
!

B. Assign the G1/0/23 to VLAN75 and G1/0/24 to VLAN85

C. Create a Switched Virtual that will operate within VLAN 75.

Switch DSW2

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW2 
! 
vlan 75 
! 
ip address 10.3.75.14 255.255.255.0 
! 
ipv6 address fe80::d2:1 link-Local 
! 
ipv6 address 2001:db8:acad:3075::d2/64 
! 
no shutdown 
! 
exit 
! 
end 
! 
write memory 
!

D. Create an IEEE 802.1Q based trunk to R3. As a part of the configuration of the trunk, set the native VLAN to VLAN 999 and filter the VLANs allowed on the trunk down to only those that are configured.

Switch DSW2

! 
Enable 
! 
configure terminal 
! 
no ip domain-lookup 
! 
hostname DSW2 
! 
interface g1/0/11 
! 
switchport trunk encapsulation dot1q 
! 
switchport mode trunk 
! 
switchport trunk native VLAN 999 
! 
switchport trunk allowed VLAN 75, 85, 999 
! 
no shutdown 
! 
exit 
! 
end 
! 
write memory 
!

Step 2. Configure R3 to support Inter-VLAN Routing

A. Configure R3 to support IPv6 unicast routing

B. Configure the sub-interfaces needed on R3 interface G0/0/1 to support the configured VLANs. Ensure an interface is created for the Native VLAN 999

C. Configure PC3 with the addresses specified in the Addressing Table. Default Gateways: 10.3.75.1 and 2001:db8:acad:3075::1

D. Configure PC4 with the addresses specified in the Addressing Table. Default Gateways: 10.3.85.1 and 2001:db8:acad:3085::1

E. From PC3, ping PC4's IPv4 and IPv6 address. Success indicates that R3 is performing Inter-VLAN Routing

Step 3. Configure static routing to enable end-to-end reachability

A. On R3, configure interface S0/1/1 with the addresses specified in the Addressing Table

B. On R3, configure a static default route for IPv4 and IPv6 that points to R1's S0/1/1 interface addresses

C. On PC3, issue a ping to PC2. The ping should be successful. This indicates the routing solution is working in both directions.

Part 4. Examine CAM & CEF Details

Cisco Express Forwarding speeds up the process of moving data from one interface to another. Data is precompiled in two tables, Forwarding Information Base (FIB) and the Adjacency Table. These provide a faster way to determine what the interface a packet egresses from should be and how it should be framed.

A. Show compiled CEF table

CEF Table tells the device how to handle a frame or packet based on its destination address in the header. It provides a quick verdict without spending CPU cycles.

show ip cef

{* - Add CEF table}

B. Show address neighbors on each interface

show adjacency
{* - Add adjacency table}

C. Show pre-compiled Layer 2 headers and other details

show adjacency detail
{* - Add adjacency detail table}

Router Interface Summary Table

Router ModelEthernet Interface #1Ethernet Interface #2Serial Interface #1Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/0/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/0 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/0 (S0/1/1)

Last updated